CORE not cycling with suppressor - MP-Pistol Forum

CORE not cycling with suppressor

This is a discussion on CORE not cycling with suppressor within the MP Full Size Pistols forums, part of the Smith & Wesson MP Forum category; HI Everyone, New member here....can't find any online help with my issue: could some of you please assist? I've had a 5" M&P CORE for ...


Go Back   MP-Pistol Forum > Smith & Wesson MP Forum > MP Full Size Pistols

Reply
 
LinkBack Thread Tools Display Modes
Old April 29th, 2017, 04:11 AM   #1
Junior Member
 
Join Date: Apr 2017
Location: East Coast
Posts: 1
CORE not cycling with suppressor

HI Everyone,

New member here....can't find any online help with my issue: could some of you please assist?

I've had a 5" M&P CORE for 2 years...VERY happy with it. However, I just got an Octane 9 suppressor and a Storm Lake threaded barrel, and now the CORE seizes up and won't cycle after 1 or 2 shots suppressed. VERY frustrating!!!

I put some lubrication on the suppressor piston and still no luck.

I'm thinking that the length of the 5" barrel might be an issue, since I shot the suppressor on a friend's 4 1/2 in M&P with no issues.

Can anyone offer a solution? What do you think is causing the problem? Thanks in advance to all of you...you guys are the best!
jamisonft is offline  
Old April 30th, 2017, 02:08 PM   #2
Member
 
Join Date: Dec 2014
Location: WA
Posts: 202
The 5" CORE should cycle just fine with a suppressor.

Define "seized up" please.
BennyRayRiddle is offline  
Old April 30th, 2017, 09:29 PM   #3
Senior Member
 
PaPow's Avatar
 
Join Date: Jul 2016
Location: NY
Posts: 1,322
Quote:
Originally Posted by jamisonft View Post
HI Everyone,

New member here....can't find any online help with my issue: could some of you please assist?

I've had a 5" M&P CORE for 2 years...VERY happy with it. However, I just got an Octane 9 suppressor and a Storm Lake threaded barrel, and now the CORE seizes up and won't cycle after 1 or 2 shots suppressed. VERY frustrating!!!

I put some lubrication on the suppressor piston and still no luck.

I'm thinking that the length of the 5" barrel might be an issue, since I shot the suppressor on a friend's 4 1/2 in M&P with no issues.

Can anyone offer a solution? What do you think is causing the problem? Thanks in advance to all of you...you guys are the best!
Does the slide cycle smoothly manually (???) Not sure i understand what the seizure issue is that your talking about...more details please.
What ammo are you using with this suppressor (???)
PaPow is offline  
Reply

  MP-Pistol Forum > Smith & Wesson MP Forum > MP Full Size Pistols

Tags
core, not cycling, suppresssed

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pro CORE mounting a red dot browningv308 MP Full Size Pistols 3 March 4th, 2017 09:11 PM
WTT - Med or Lrg Core Backstrap for Small Core Backstrap Beefstews Classifieds 5 January 15th, 2017 07:19 AM
WTT- CORE 5" upper for 4 1/2" upper. Magnum1b MP Full Size Pistols 3 December 23rd, 2016 02:07 AM
Suppressor opens groups up by 2x LoneStarWings MP Pistol Tech Help 10 September 15th, 2016 05:24 PM
WTB: 9mm 5inch 9L M&P Performance Center Ported CORE Slide assembly zupreme Classifieds 12 August 1st, 2016 12:13 PM



Powered by vBulletin 3.8.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright © 2006-2012 MP-Pistol. All rights reserved.
MP-Pistol is a M&P pistol enthusiast forum, but it is in no way affiliated with, nor does it represent Smith & Wesson Holding Corp. of Springfield, MA.