Trijicon rm06 issues on my CORE. Need help! - MP-Pistol Forum

Trijicon rm06 issues on my CORE. Need help!

This is a discussion on Trijicon rm06 issues on my CORE. Need help! within the MP Pistol Accessories forums, part of the Smith & Wesson MP Forum category; Hey guys so I have an issue with my new trijicon rm06 rmr. I recently just purchased the rmr , installed it on my pistol ...


Go Back   MP-Pistol Forum > Smith & Wesson MP Forum > MP Pistol Accessories

Reply
 
LinkBack Thread Tools Display Modes
Old August 5th, 2014, 07:32 AM   #1
Junior Member
 
Join Date: Aug 2014
Location: illinois
Posts: 4
Trijicon rm06 issues on my CORE. Need help!

Hey guys so I have an issue with my new trijicon rm06 rmr. I recently just purchased the rmr , installed it on my pistol and took it too the range and shot about 250 rounds through it. Everything worked perfect . Every shot is right on point with the red dot. I decided to take my gun out the other day to practice acquiring my sight picture and feeling out my trigger reset because I did install the Apex competition trigger kit in my gun . So I pulled the slide back and locked it in , as I released the slide the red dot itself on setting 3 or 4 dims out or even shuts off until I adjust the brightness to get it back on. Has anyone had this issue before with the sight dimming/shuts off at random times(only when the slide is in action)? The battery came in a sealed bag so I'm assuming the battery is still good? I took the battery out and placed it back in and it still does it...
elliotyee215 is offline  
Old August 5th, 2014, 07:35 AM   #2
Junior Member
 
Join Date: Aug 2014
Location: illinois
Posts: 4
If this is not an issue I can fix myself can someone tell me how trijicon customer service is? And what I would need to do? Do I have to fill out the warranty card and send it in to them before they can work on it?
elliotyee215 is offline  
Old August 5th, 2014, 09:44 AM   #3
Member
 
Join Date: Mar 2010
Location: WS, Ma.
Posts: 499
I would definitely try a new battery first....
Turbo38GN is offline  
Old August 5th, 2014, 12:22 PM   #4
Member
 
Join Date: Oct 2012
Location: Wisconsin
Posts: 144
I have 3 RMR's on M&P's and had several Glocks also but I have not had that problem.
I had an intermittent on and off problem until I used the piece of tape trick, mentioned below.
Several things to check.
Are you possibly inadvertently pushing either of the buttons when you operate the slide?
Just had a friend running one of my guns and the dot kept changing and I figured out he was pressing one button or the other when he grabbed the slide to rack it.
Are the screws tight, I would try another battery, never hurts.
On the CORE can you use the plate that Trijicon makes to place under the RMR when mounting on a machined slide? If not, try putting just one layer thick of electrical tape
on the slide and then put on the RMR. This trick has helped solve many problems.
Trijicons service is top shelf and if you want more info on running an RMR and any problems check out the Warrior Talk forum, more info there than any where else.
babue is offline  
Old August 5th, 2014, 12:34 PM   #5
Junior Member
 
Join Date: Aug 2014
Location: illinois
Posts: 4
Unfortunately I am not pressing the buttons when I fire it. I been talking on other forums also and a couple other people are having the flickering dimming effects , I am probably going to change the battery and do the tape trick . I thought it was the rmr itself that's bad but I'm thinking there might just be enough wiggle room between the battery and the plate to cause the battery to move slighty, and I do have the screws as tight as they can go.

Quote:
Originally Posted by babue View Post
I have 3 RMR's on M&P's and had several Glocks also but I have not had that problem.
I had an intermittent on and off problem until I used the piece of tape trick, mentioned below.
Several things to check.
Are you possibly inadvertently pushing either of the buttons when you operate the slide?
Just had a friend running one of my guns and the dot kept changing and I figured out he was pressing one button or the other when he grabbed the slide to rack it.
Are the screws tight, I would try another battery, never hurts.
On the CORE can you use the plate that Trijicon makes to place under the RMR when mounting on a machined slide? If not, try putting just one layer thick of electrical tape
on the slide and then put on the RMR. This trick has helped solve many problems.
Trijicons service is top shelf and if you want more info on running an RMR and any problems check out the Warrior Talk forum, more info there than any where else.
elliotyee215 is offline  
Old August 5th, 2014, 01:37 PM   #6
Member
 
Join Date: Oct 2012
Location: Wisconsin
Posts: 144
Quote:
Originally Posted by elliotyee215 View Post
Unfortunately I am not pressing the buttons when I fire it. I been talking on other forums also and a couple other people are having the flickering dimming effects , I am probably going to change the battery and do the tape trick . I thought it was the rmr itself that's bad but I'm thinking there might just be enough wiggle room between the battery and the plate to cause the battery to move slighty, and I do have the screws as tight as they can go.
Try the tape trick and new battery, if that does not fix it I would call Trijicon, they have very good customer service. I change my batteries once a year and buy top quality replacements. The battery should last much longer but once per year is good enough for me.
Good luck, let us know when you solve the problem.
babue is offline  
Old August 5th, 2014, 08:35 PM   #7
Junior Member
 
Join Date: Aug 2014
Location: illinois
Posts: 4
Thanks for the help. Hope this thread is helping others who are choosing what optics they want .
elliotyee215 is offline  
Old May 4th, 2016, 06:49 PM   #8
Member
 
Join Date: Apr 2016
Location: Miami,Florida
Posts: 39
Excellent pointers- thanks
seafbyrd is offline  
Old May 4th, 2016, 07:51 PM   #9
Senior Member
 
Join Date: Jan 2016
Location: Central Maine
Posts: 579
My understanding is that this issue has been fixed in current production RMRs.

I've had mine for awhile with no problems at all.

If I remember correctly it was a problem with the spring that makes contact with the battery.
BrianK is offline  
Old July 25th, 2016, 10:18 PM   #10
Junior Member
 
Join Date: Feb 2016
Location: USA
Posts: 11
Had a current production received in May. Mine did the same thing. Placed the thick vinyl type electrical tape under battery. Easy fix no problems !!
Davidp is offline  
Old August 19th, 2016, 02:01 PM   #11
Junior Member
 
Join Date: Jun 2015
Location: Upstate SC
Posts: 23
No worries, tape helped but the real solution was to move the small lever that contacts the OD of the battery toward the center so that more forceful contact is made with the battery rim.
Smokey99 is offline  
Old November 25th, 2016, 07:36 PM   #12
Junior Member
 
Join Date: Aug 2016
Location: NC
Posts: 6
Mine is doing the exact same thing. ill try the tape trick tomorrow. It's a little discouraging that a $500 optic would have an issue like this.
Mtnman1 is offline  
Old January 16th, 2017, 07:19 AM   #13
Member
 
steved13's Avatar
 
Join Date: Dec 2016
Location: St Petersburg FL
Posts: 78
My RM06 is arriving today. I did a little looking around and I wonder if the Sealing plate might not have helped with this issue. By description, the sealing plate should be used with the CORE (from the way I understand it) and that should lock the battery in better.

Just thought I'd throw it out there in case it helps someone.
steved13 is offline  
Reply

  MP-Pistol Forum > Smith & Wesson MP Forum > MP Pistol Accessories


Search tags for this page
has trijicon fixed problems with rmr on pistols
,

problems with trijicon rmr

,

trijicon rm06

,

trijicon rm06 issues

,
trijicon rmo6 turns off
,

trijicon rmr 06 issues

,

trijicon rmr flickering

,

trijicon rmr issues

,

trijicon rmr problems

,
trijicon rmr problens
,

trijicon rmr shutting off

,

trijicon rmr tape trick

Click on a term to search for related topics.

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
CORE Dan m&p 45c MP Pictures 4 May 18th, 2013 12:09 PM
Core 40s KyCarry MP Full Size Pistols 4 May 12th, 2013 06:00 PM
M&Pc CORE Rem700 MP Compact Pistols 6 May 5th, 2013 01:23 PM
WTB M&P PRO CORE 9L DnvrSmity Classifieds 0 April 30th, 2013 12:04 PM
M&P Pro CORE Backstrap shipping with non-CORE AtomicToaster MP Talk 4 March 24th, 2013 04:13 PM



Powered by vBulletin 3.8.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright © 2006-2012 MP-Pistol. All rights reserved.
MP-Pistol is a M&P pistol enthusiast forum, but it is in no way affiliated with, nor does it represent Smith & Wesson Holding Corp. of Springfield, MA.