Trijicon RM07 issues on CORE - MP-Pistol Forum

Trijicon RM07 issues on CORE

This is a discussion on Trijicon RM07 issues on CORE within the MP Pistol Accessories forums, part of the Smith & Wesson MP Forum category; I purchased a RM07 from Optics Planet w/6.5 dot three weeks ago to mount on my 9L CORE. Now I have used Trijicon products in ...


Go Back   MP-Pistol Forum > Smith & Wesson MP Forum > MP Pistol Accessories

Reply
 
LinkBack Thread Tools Display Modes
Old February 20th, 2016, 07:04 AM   #1
Junior Member
 
XringAO's Avatar
 
Join Date: Jan 2016
Location: Queen Creek AZ
Posts: 8
Exclamation Trijicon RM07 issues on CORE

I purchased a RM07 from Optics Planet w/6.5 dot three weeks ago to mount on my 9L CORE. Now I have used Trijicon products in Central and South America and Bosnia on M4's never having issue one. Harsh conditions, harsh use, no problems. Stands to reason that the RM07 would perform at least as good as the ACOG and some earlier versions of same.

Not so with the RM07. I mounted the optic with the correct CORE mounting plate and followed the directions to the letter in sighting in the optic. All of the controls seemed to function as expected. Upon initial firing/sighting in, after 20 rounds of 115g FMJ(mild load, 1000fps) the dot began to dim and eventually left the range!

First I made contact with Optics Planet and asked if there were any known issues like the one I had. The response from CS was "Dude, we have never had problems with the MR's", "Better call Trijicon".

Called Trijicon CS and was informed that "some early MR's that use a battery had that problem" I asked what the manufacturing date was on my unit and gave him the serial number.....hummm. Seems it was made two months ago. He went on "You should send it back to us(wanted me to pay shipping both ways) and we will put upgraded battery contacts", "It will take about 6 weeks" SIX WEEKS SAY I. How about an exchange? "Not our policy says he" End of conversation!!

Because he mentioned 'battery' I examined the surface of the battery that faces the mount....sure enough, there is a pronounced Arc divot! I put two layers of high quality 3m electrical tape between the mount and battery and hey, it now works great. So much for Trijicon CS and policy.

Thought this might help some of you that might be struggling with the same issue.
XringAO is offline  
Old March 29th, 2016, 06:54 AM   #2
Member
 
Gigantore's Avatar
 
Join Date: Nov 2015
Location: Florida
Posts: 36
Interesting. thanks for sharing. Im in the market for one for my CORE 5". Im probably going to go with Vortex or Burris. They both have amazing customer service.
Gigantore is offline  
Old March 29th, 2016, 04:59 PM   #3
Member
 
Join Date: Oct 2012
Location: Virginia
Posts: 253
I've seen that fix stated on other forums. No idea why the maker doesn't just insure the contacts are at the right angle/clearances prior to shipment.
M1A4ME is offline  
 
Old March 29th, 2016, 05:06 PM   #4
Member
 
Join Date: Dec 2014
Location: Ohio
Posts: 168
Quote:
Originally Posted by XringAO View Post
I purchased a RM07 from Optics Planet w/6.5 dot three weeks ago to mount on my 9L CORE. Now I have used Trijicon products in Central and South America and Bosnia on M4's never having issue one. Harsh conditions, harsh use, no problems. Stands to reason that the RM07 would perform at least as good as the ACOG and some earlier versions of same.

Not so with the RM07. I mounted the optic with the correct CORE mounting plate and followed the directions to the letter in sighting in the optic. All of the controls seemed to function as expected. Upon initial firing/sighting in, after 20 rounds of 115g FMJ(mild load, 1000fps) the dot began to dim and eventually left the range!

First I made contact with Optics Planet and asked if there were any known issues like the one I had. The response from CS was "Dude, we have never had problems with the MR's", "Better call Trijicon".

Called Trijicon CS and was informed that "some early MR's that use a battery had that problem" I asked what the manufacturing date was on my unit and gave him the serial number.....hummm. Seems it was made two months ago. He went on "You should send it back to us(wanted me to pay shipping both ways) and we will put upgraded battery contacts", "It will take about 6 weeks" SIX WEEKS SAY I. How about an exchange? "Not our policy says he" End of conversation!!

Because he mentioned 'battery' I examined the surface of the battery that faces the mount....sure enough, there is a pronounced Arc divot! I put two layers of high quality 3m electrical tape between the mount and battery and hey, it now works great. So much for Trijicon CS and policy.

Thought this might help some of you that might be struggling with the same issue.
This post may have cost them a sale, mine. I have heard of issues with some slide mounted RMR's. I have 2 Vortex products, neither of them dots, and they may get my business for my CORE.

6 weeks to fix battery contacts and shipping both ways is poor CS.
lhawkins is offline  
Old March 29th, 2016, 07:43 PM   #5
Member
 
Join Date: Oct 2012
Location: Wisconsin
Posts: 145
The electrical tape fix is a common thing. Not so much with the newest models but with older ones, more so. Something even better is to put a small dab of silicon sealer on the mounting plate, right where the battery lays, let it setup for 10 minutes and then mount the RMR. That pushes the battery up and keeps it from wiggling. The side contact is the one most likely to need a slight bending out to insure solid contact. I have 4 RMR's, 2 on M&P's and 2 on Glocks, nothing is perfect but they have all performed well for multiple years. I did send one in and while Trijicon said 6 weeks it was only 3 and they replaced the lens that had scratches in it, no questions asked.
For a range gun, use what ever you want, for a gun I will bet my life on, I prefer to
use the best available and that is still the RMR's.
babue is offline  
Reply

  MP-Pistol Forum > Smith & Wesson MP Forum > MP Pistol Accessories

Tags
core, rmr, trijicon


Search tags for this page
mounting a trijicon on a core pistol
,

rm07 m&p core

,

trijicon mounted in core

,
trijicon mounted on core
,
trijicon rm07 problems
Click on a term to search for related topics.

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trijicon rm06 issues on my CORE. Need help! elliotyee215 MP Pistol Accessories 13 January 22nd, 2017 10:45 AM
Range Report: M&P CORE w/ Trijicon RMR & StormLake Ported Barrel & Apex Comp Kit mesinge2 MP Range Reports 7 July 3rd, 2015 07:19 PM
WTS Trijicon RMR RM07 Masda86 Classifieds 0 June 4th, 2015 10:03 AM
M&P Pro CORE Backstrap shipping with non-CORE AtomicToaster MP Talk 4 March 24th, 2013 04:13 PM
M/P Pro And Trijicon demusn1979 MP Pistol Accessories 16 June 4th, 2009 03:52 PM



Powered by vBulletin 3.8.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright © 2006-2012 MP-Pistol. All rights reserved.
MP-Pistol is a M&P pistol enthusiast forum, but it is in no way affiliated with, nor does it represent Smith & Wesson Holding Corp. of Springfield, MA.