feed issue - MP-Pistol Forum

feed issue

This is a discussion on feed issue within the MP Pistol Tech Help forums, part of the Smith & Wesson MP Forum category; I just bought a new pro series9mm with 5 inch barrel, when I go to load it with slide lock back I insert mag and ...


Go Back   MP-Pistol Forum > Smith & Wesson MP Forum > MP Pistol Tech Help

Reply
 
LinkBack Thread Tools Display Modes
Old August 15th, 2016, 11:06 AM   #1
Member
 
Join Date: Jun 2008
Posts: 37
feed issue

I just bought a new pro series9mm with 5 inch barrel, when I go to load it with slide lock back I insert mag and pull slide and release and even if it goes it catching and then shoots forward and loads, 3 times it stopped. is shooting the best thing for now to see if it loosens up or have I got a problem.
pochis is offline  
Old August 15th, 2016, 01:11 PM   #2
Senior Member
 
Join Date: Jan 2016
Location: Central Maine
Posts: 639
What ammo?

Most feeding issues can be traced to the magazine. Does it happen with all mags or just one? I would check the feed lips to see if there are any burrs or anything obvious. Does it happen only when the mag is full or at random times during a mag dump? Check to make sure the mag isn't rubbing on the bottom of the slide. Oh, a S&W OEM mag or brand x?

Has the gun been lubricated?

I know you said you pull and release. :-) My brother did too and followed the slide forward with his hand despite me telling him to pull and release. If you are, don't ride the slide forward.

If all of the above doesn't help I'd make sure it's lubed and fire it. Or cycle it by hand a few hundred times to see if that helps it.

Good luck with it and please keep us in the loop.
BrianK is offline  
Old August 15th, 2016, 02:15 PM   #3
Member
 
Join Date: Jun 2008
Posts: 37
so far all ammo I tried, yes lubed, the pull and release I've done both. I will get to range either tues or wed.
pochis is offline  
Reply

  MP-Pistol Forum > Smith & Wesson MP Forum > MP Pistol Tech Help

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Failure to feed issue cbpat1 MP SHIELD Pistols 9 July 1st, 2016 11:09 AM



Powered by vBulletin 3.8.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright © 2006-2012 MP-Pistol. All rights reserved.
MP-Pistol is a M&P pistol enthusiast forum, but it is in no way affiliated with, nor does it represent Smith & Wesson Holding Corp. of Springfield, MA.