New Shield 9 owner here - MP-Pistol Forum

New Shield 9 owner here

This is a discussion on New Shield 9 owner here within the MP SHIELD Pistols forums, part of the Smith & Wesson MP Forum category; I finally took my shield out today and ran 70 rounds of Freedom Munitions 124 gr RN through with one small hiccup. The slide wouldn't ...


Go Back   MP-Pistol Forum > Smith & Wesson MP Forum > MP SHIELD Pistols

Reply
 
LinkBack Thread Tools Display Modes
Old August 19th, 2016, 07:19 PM   #1
Junior Member
 
Join Date: Aug 2016
Location: Eastern Shore VA
Posts: 5
New Shield 9 owner here

I finally took my shield out today and ran 70 rounds of Freedom Munitions 124 gr RN through with one small hiccup. The slide wouldn't come forward unless I tapped the back of the slide. It happened with all three mags(2 8rd mags and 1 7rd mag), but only happened after 1 or 2 rounds and then the rest of rounds cycled with no problems. I like the gun, but this is worrisome as it's a new gun I considering as my new EDC.

The accuracy at 21 feet is good, but I need to get used to the gun. Hopefully the gun and I will perform better during the 2nd range visit.
Attached Images
File Type: jpg Shield Range Session #1.jpg (192.4 KB, 37 views)
esvarocketman is offline  
Old August 19th, 2016, 09:02 PM   #2
G56
Site Staff
 
G56's Avatar
 
Join Date: Sep 2006
Location: Oklahoma
Posts: 8,920
Did you clean and lube it before you shot it? In any case it just needs to be shot to break it in.
G56 is offline  
Old August 20th, 2016, 03:43 AM   #3
Member
 
Kooi's Avatar
 
Join Date: Jul 2016
Location: Miami
Posts: 101
Quote:
Originally Posted by G56 View Post
Did you clean and lube it before you shot it? In any case it just needs to be shot to break it in.
2nd this!
Kooi is offline  
 
Old August 20th, 2016, 03:57 AM   #4
Junior Member
 
Join Date: Aug 2016
Location: Eastern Shore VA
Posts: 5
Yep I cleaned and lubed the gun up before I shot her. She's a sweet gun, so basically it just needs to be broken in. Gonna take the shield out today and run a box or 2 through before the wife gets back from shopping.
esvarocketman is offline  
Old August 20th, 2016, 04:27 AM   #5
Member
 
Rado's Avatar
 
Join Date: Aug 2015
Location: Maine
Posts: 273
CONGRATS on your new Shield and WELCOME to the group!
I have run assorted Freedom Ammo and Federals w/o a issue..
May I suggest you try other ammo as well as this batch may be slightly undercharged ? Mine fires 115/124 RN HP etc. If you still have a issues after another 50/100 rounds I would call CS at S&W . And maybe a Gunsmith at your LGS may be able to look at it! Please update us on what happen .s later.
Also look at the UPLULA Magazine loader around 28/35$
maglula | Tools for loading and unloading magazines


and Makershot Loader 12$
Makershot Speedloader Smith Wesson M P Shield 9mm 40 s w Magazine Loader | eBay
and Talon Grip Tape for a better feel
TALON Grips for Glock, XD, XDM, Kahr, Ruger and Kel-Tec Pistols. Free Shipping!
Rado is offline  
Old August 20th, 2016, 05:26 AM   #6
Senior Member
 
Texas40's Avatar
 
Join Date: Apr 2013
Location: San Antonio Texas
Posts: 639
Try a little polishing on the feed ramp.
And shoot it some more.
My 1911 was doing similar on the last round only needed a new mag as spring was weak and the last round would not quite make it up enough.


I Live For Myself and I Answer to No One.
Texas40 is offline  
Old August 20th, 2016, 12:02 PM   #7
Senior Member
 
Jaysq's Avatar
 
Join Date: Oct 2013
Location: North Carolina
Posts: 1,065
Welcome from North Carolina
Jaysq is offline  
Old August 20th, 2016, 12:21 PM   #8
Senior Member
 
Rick M's Avatar
 
Join Date: Nov 2008
Location: Weeki Wachee, FL
Posts: 1,862
If it's only happening with the first 1-2 rounds per mag; I'm guessing that it's the new mag springs.

Leave the mags fully loaded for a few days for the springs to take their "set;" and see if the issue goes away.

I've had that happen with a variety of auto pistols over the years; it's not brand or mag specific, although it does happen more often with the higher cap single stack mags.

I've never seen an M&P barrel that didn't come fairly well "polished" to begin with.

Last edited by Rick M; August 27th, 2016 at 10:25 AM.
Rick M is offline  
Old August 20th, 2016, 03:04 PM   #9
Member
 
Join Date: Apr 2016
Location: Texas
Posts: 61
It DEFINITELY needs breaking in. Mine used to do that once in a blue moon but not anymore. (2500rds)

And its not fair to slight the gun when your shooting FreedomMunitions. Like said above, get some real ammo and run through it.

Takes about 500 to get her good and broke in.
DadRoman is offline  
Old August 20th, 2016, 05:12 PM   #10
Junior Member
 
Join Date: Aug 2016
Location: Eastern Shore VA
Posts: 5
Thanks for the warm welcome everyone. Tonight was better. I ran a 50 round mixture of Fiocchi 124 GR RN & JHP. My shield performed perfect. No hang ups. I'm starting to question Freedom Munitions quality. It burns clean but you could tell a difference between the bang of fiocchi when compared to freedom munitions.
esvarocketman is offline  
Old August 20th, 2016, 06:08 PM   #11
Senior Member
 
Rick M's Avatar
 
Join Date: Nov 2008
Location: Weeki Wachee, FL
Posts: 1,862
Quote:
Originally Posted by DadRoman View Post
It DEFINITELY needs breaking in. Mine used to do that once in a blue moon but not anymore. (2500rds)

And its not fair to slight the gun when your shooting FreedomMunitions. Like said above, get some real ammo and run through it.

Takes about 500 to get her good and broke in.
None of my M&P's have required "breaking in" to function reliably.

As far as using Freedom Munitions ammo; I've shot many thousands of rounds of it, including several 1500 round count weekend training classes, with zero malfunctions.

I believe that over 50% of the folks that I've trained with, and currently and shoot IDPA with, use FM ammo.

Last edited by Rick M; August 20th, 2016 at 06:16 PM.
Rick M is offline  
Old August 20th, 2016, 07:48 PM   #12
G56
Site Staff
 
G56's Avatar
 
Join Date: Sep 2006
Location: Oklahoma
Posts: 8,920
Not every pistol likes every ammo, some combinations will be problematic, no fault to either the pistol or the ammo. Call it karma if you like, a individual pistol might not feed brand X ammo worth a darn, even though others just like it will feed and function perfectly with the same ammo, nobody knows why, it just happens. If you find one YOUR PISTOL doesn't like, best advice is don't buy that ammo anymore, there's plenty others available.
G56 is offline  
Old August 20th, 2016, 08:36 PM   #13
Member
 
jstanfield103's Avatar
 
Join Date: Aug 2013
Location: Kentucky
Posts: 124
With a good break in the pistol will probably run just fine. Not every pistol needs a break in. In fact most do not but occasionally the chamber or feed ramp is not as polished or a little tight and a break in of 500 round or so is needed. Welcome to the forum and congratulations on the new Shield, I Love both of mine (9mm and 45 acp.)
jstanfield103 is offline  
Old August 21st, 2016, 08:46 AM   #14
Senior Member
 
LordRahl's Avatar
 
Join Date: Feb 2008
Location: Northen VA
Posts: 3,830
Ditto on cleaning and polishing of the feed ramp.
LordRahl is offline  
Old August 27th, 2016, 08:30 AM   #15
Junior Member
 
Join Date: Aug 2016
Location: Eastern Shore VA
Posts: 5
Second range session with my Shield. Ran 60 trouble free rounds through the gun. It feels like the gun is rotating in my hand still, which explains why my groupings are left. I'm trying to get used to the shield, but I'm considering going to the M&P9c and hand the shield to my wife.
Attached Images
File Type: jpg 1472315167531725415871_1472315222423.jpg (1.43 MB, 10 views)
esvarocketman is offline  
Reply

  MP-Pistol Forum > Smith & Wesson MP Forum > MP SHIELD Pistols

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ported Shield V/s non ported browningv308 MP SHIELD Pistols 26 October 26th, 2016 07:35 AM
Bought second Shield for my wife WPA MP SHIELD Pistols 11 August 28th, 2016 10:28 AM
Happy Owner -- Gripe elsewhere! haroldg48 MP SHIELD Pistols 26 July 3rd, 2016 02:19 PM
new shield owner from Florida sabrecrash New Users 7 June 29th, 2016 02:31 PM
New Shield owner Jamming New Users 12 June 12th, 2016 03:48 PM



Powered by vBulletin 3.8.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright © 2006-2012 MP-Pistol. All rights reserved.
MP-Pistol is a M&P pistol enthusiast forum, but it is in no way affiliated with, nor does it represent Smith & Wesson Holding Corp. of Springfield, MA.