New: M&P 40 spring and slide failing to return forward. - MP-Pistol Forum

New: M&P 40 spring and slide failing to return forward.

This is a discussion on New: M&P 40 spring and slide failing to return forward. within the Polls forums, part of the Smith & Wesson MP Forum category; By popular demand! Problem with slide not going fully foward. Which spring did you have? Factory blue color spring or factory green color spring? This ...


Go Back   MP-Pistol Forum > Smith & Wesson MP Forum > Polls

View Poll Results: Which case are you?
Experienced a problem wih blue spring. 1 2.44%
Experienced problems with blue spring on 2 different pistols. 1 2.44%
Experienced problems with blue spring on more than 2 different pistols. 1 2.44%
Experinced no problem with blue spring. 32 78.05%
Experienced a problem with green spring. 1 2.44%
Experienced problems with green spring on 2 different pistols. 0 0%
Experienced problems with blue spring on more than 2 different pistols. 0 0%
Experinced no problem with green spring. 14 34.15%
Multiple Choice Poll. Voters: 41. You may not vote on this poll

Reply
 
LinkBack Thread Tools Display Modes
Old September 18th, 2013, 04:29 PM   #1
Member
 
Join Date: Oct 2012
Location: Los Angeles
Posts: 146
New: M&P 40 spring and slide failing to return forward.

By popular demand!

Problem with slide not going fully foward.

Which spring did you have?

Factory blue color spring or factory green color spring?

This is exclusive to M&P40 full size.

Multiple choices allowed.

Last edited by grayblue; September 18th, 2013 at 05:14 PM.
grayblue is offline  
Old September 18th, 2013, 05:34 PM   #2
Senior Member
 
jasonuscg's Avatar
 
Join Date: Dec 2009
Location: Salish Sea
Posts: 4,539
Quote:
Originally Posted by grayblue View Post
By popular demand!

Problem with slide not going fully foward.

Which spring did you have?

Factory blue color spring or factory green color spring?

This is exclusive to M&P40 full size.

Multiple choices allowed.
When the slide is "fully forward" the proper term is the slide is "in battery."
jasonuscg is offline  
Old October 4th, 2013, 04:47 AM   #3
Senior Member
 
JeffWard's Avatar
 
Join Date: Oct 2008
Location: St Petersburg, FL
Posts: 3,552
My carry 40 (less than 6 mos old) has a blue spring with no issues through a few thousand rounds.

My competition 40 has a 13# Wolff spring in it, and has gone into battery without issues for over 10,000 rounds.

JeffWard
JeffWard is offline  
 
Old October 4th, 2013, 11:46 AM   #4
Senior Member
 
Rick M's Avatar
 
Join Date: Nov 2008
Location: Weeki Wachee, FL
Posts: 1,760
Oops!

I thought that I was voting for "experienced NO problems with blue spring on more than two pistols;" but voted incorrectly that I had problems with BS on more than two pistols.

Apparently, that choice is listed twice, while a choice of no problems with more than two, etc. isn't available.

Rick
Rick M is offline  
Reply

  MP-Pistol Forum > Smith & Wesson MP Forum > Polls


Search tags for this page

m p 40 return spring

Click on a term to search for related topics.

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slide fail to return to full forward position problem and spring issue. grayblue Polls 13 September 18th, 2013 04:40 PM
M&P22 Failing To Cycle. Slide hanging up. williaty MP Pistol Tech Help 14 January 19th, 2013 01:57 AM
WTB: M&P Trigger return spring hk-sigman Want To Buy 0 October 14th, 2008 05:05 PM
Trigger Return Spring Ungas MP Gunsmithing 15 August 20th, 2008 07:46 AM



Powered by vBulletin 3.8.7
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright © 2006-2012 MP-Pistol. All rights reserved.
MP-Pistol is a M&P pistol enthusiast forum, but it is in no way affiliated with, nor does it represent Smith & Wesson Holding Corp. of Springfield, MA.